Checklist Report

Checklist Report - Overview

The checklist report is completely customizable by the user and therefore has many uses. Some uses include:

·        Well Inspection Report

·        Results of Location or Interval Survey Information

·        Logging Meta Information

An example report from the checklist tool is shown below:

image

 

 

Checklist Report – Setting up List Items

Tool Location:                                                 

Tools > Reference Setup > Checklist Items

The Checklist Items tools allows you to:

·         Create different checklist names for different reporting purposes

·         Enter the question or text for each item you wish to have in the report

·         Decide whether an item requires a Yes/No response, its default answer, and the format of the response entry

·         Decide whether an item requires a dropdown response, its default answer, and the format of the response entry

·         Decide whether an item requires a text response (i.e., an area where additional notes can be written), and the format of the response entry.

·         Choose the order that the items appear

·         Hide items from lists and reports

The form used to manage this information is displayed below.

image

Creating a Checklist Name

Enter a checklist name in the column called Checklist Name, and save the record, a new checklist name can be saved into the database. Users can choose the checklist names that are already saved in the database.

Adding / Deleting Items

Usage of the form is fairly self explanatory. Use the Add Record and Delete Record buttons to add and remove items from the list.

Using the Check Boxes to choose Required Responses

There are 3 types of responses to each checklist item (record):

·         Yes / No

·         Dropdown

·         Text

Dropdown list entries will be populated by entering a semi-colon separated list (e.g., response A;response B;response C).

 

For each response listed above, there are 3 check mark options that users can choose to the check boxes:

·         Not Needed

·         Optional

·         Required

Place needed check marks in the desired columns.

Entering Default Reponses

Default responses can be specified for the required 'Yes/No' and dropdown responses.

Choose Response Entry Formats

For the dropdown responses, users can choose a data entry format from one of the following 4 options:

·         Text, limit to list

·         Numeric, limit to list

·         Text, do not limit to list

·         Numeric, do not limit to list

If none of the above options is chosen, then both texts and numbers can be entered and the responses are not limited to the list.

 

For the text responses, users can choose a data entry format from one of the following 2 options:

·         Text

·         Numeric

If none of the formats is chosen, then both texts and numbers can be entered.

 

Setting the List Order

Enter numbers in the List Order column to set the order. It does not matter what numbers are used or if there are gaps in the numbering, SiteFX will simply sort whatever numbers are present in ascending order.

The 'Up' and 'Down' buttons move the items up and down in the form, but this order is not saved to the database.

 

Hiding the List Items

Place check marks in the column 'Hide Item' to hide the items from the checklist reports.

Checklist Report – Entering Data

Tool Location:                                                 

Locations > Location Explorer > User Action (find and highlight the desired location) > Location Editor button > Checklist tab

By default, the Location Editor is in Browse mode which means data can only be viewed. In order to enter data, you must press 'Edit' button.

image

Entering Data

The entry part of the form is shown below.

image

Choose a checklist name. Enter a date first (double click this field for a calendar if desired). The time is optional and is entered in 24-hour format. Once the date and time are entered press the Add button. The report for that date and time will immediately become active and you can fill out the report.

Each checklist item in the report has 2 rows and 3 columns. The 1st column in a report shows the order of the checklist items. The 2nd column with the title 'Check Content / Check Result Text' means the first row of this item in this column is the 'Check Content' (or also called Check Question, Check Text), while the second row means the response text to be entered by the user. The 3rd column with the title 'YN / Dropdown' means the first row of this column is the 'Yes / No' response, and the second row means the dropdown response to be entered by the user.

The red color cells mean the responses are required. The green color cells mean the responses are optional. To save the data, press the 'Save' button. To edit the data, press the 'Edit' button.

Searching and Viewing Existing Reports

The existing checklist reports can be searched by the checklist template names, and  year/month that the reports were created.

All existing reports are listed under the Existing Reports section in the left-hand of the section. Simply click on the name (date/time) of the report you wish to view and the information for that report will be shown on the form.

Deleting a Report

Highlight the report you wish to delete from the list of existing reports first and then press the Delete button. You will be asked to confirm before the deletion is completed.

Checklist Report – Printing Reports – Single Location or Interval

Tool Location:                                                 

Locations > Location Explorer > User Action (find and highlight the desired location or interval) > Location Editor button > Checklist tab

If you just need to print one or more reports for a single location or interval, you can print reports directly from the Location Editor form. If you need to print reports for multiple locations or intervals, see thing section called Checklist Report – Printing Reports – Multiple Locations or Intervals.

Printing Reports

Bring up the location or interval you wish to print the report for in the Location Editor and go to the Checklist tab.

If you just require one report printed, pick the date of the report you wish to print and press the Print Selected button.

If you need several reports, press the Print Multiple button. This will bring up an additional dialog that allows you to select the date range for the reports you wish to print. This dialog is shown below.

The dialog has a default range of one year. You also have the option of filtering the reports to only those that have a ‘No’ response.  Press the Preview button and you will be able to see the reports before sending them to the printer. A selector at the bottom of the preview window will allow you to scroll through the pages.

Print to a printer using the Print option located under the File menu. An example report from the checklist tool is shown in Section Checklist Report - Overview.

 

image

 

Checklist Report – Printing Reports – Multiple Locations or Intervals

Tool Location: Locations > Location Explorer > User Action (find and highlight one or more locations or intervals) > User Action (choose the Checklist report from the drop down list under the Multiple Selection > Reports category)

You can also print the reports for several locations at the same time right from the Location Explorer form. The key sections of this form have been highlighted below.

image

Printing Reports

Select one or more locations or intervals in the location explorer. Next choose Checklist from the list of items located under the Multiple Selection category and press the Go button. This will bring up an additional dialog that allows you to select the date range for the reports you wish to print. This dialog is shown below.

image

The dialog has a default range of one year. You also have the option of filtering the reports to only those that have a ‘No’ response. Press the Preview button and you will be able to see the reports before sending them to the printer. A selector at the bottom of the preview window will allow you to scroll through the pages.

Print to a printer using the Print option located under the File menu.